Log In

IntelliBoard 5.0 is here!
The 5.0 plugin and 5.0 credentials are necessary to utilize IntelliBoard 5.0.

  • IntelliBoard 4.8

    Select Platform
    Existing IntelliBoard users with a 4.8 plugin or lower should click “Select Platform” above to continue using IntelliBoard 4.8. NOTE: The 5.0 plugin is not supported by 4.8 credentials.
  • IntelliBoard 5.0

    Select Platform
    To utilize IntelliBoard 5.0, you must install the 5.0 plugin and sign up for new 5.0 credentials. Existing clients may request their plans transition from 4.8 to 5.0 by emailing Support@IntelliBoard.net